how to resolve compatibility issue with firefox 9 add ons